A Mozilla agora faz modificações na sua instalação do Firefox sem sua permissão

Minutos atrás eu me surpreendi ao ver um novo ícone exibindo uma tesoura aparecer na barra de ferramentas do Firefox. Ao colocar o mouse por cima dele vi que se tratava de um tal “Firefox Screenshots” do qual eu nunca ouvira falar. Pesquisando no Google descobri que trata-se de uma funcionalidade até útil, e quem usa o Firefox 55 deve mesmo esperar que apareça “de uma hora para outra” no navegador.

Então eu fui me certificar das minhas configurações para atualização do Firefox e está lá o que eu marquei depois de instalar: “Check for updates, but let you choose whether to install them”.

Ou seja: eu explicitamente disse ao navegador para não instalar atualizações sem minha permissão e a Mozilla modificou meu navegador assim mesmo.

A arrogância desse pessoal não pára de me surpreender.

E tem mais: No histórico de atualizações não aparece nada. Nem na lista de complementos. Ou seja, o Firefox está copiando do Chrome até o comportamento de malware.

 

10 comentários
  • João Batista - 30 Comentários

    OK então ir para qual navegador ?

    • Luciano - 443 Comentários

      Talvez usar a versão ESR e segurar as broncas em atualizar até onde der… Eu cheguei a fazer isso, fiquei anos com o Firefox 26 até onde deu pra aguentar, e alguns sites importantes passaram a deixar de funcionar, dai pulei pro ESR e estou travado por enquanto na versão 45.9.0 e estou segurando de atualizar, pois um update que teve logo apos estes, quebrou um monte de plugins que eu uso e não consegui por pra funcionar de novo. Dai… fiz rollback e cá estamos.

      • Jefferson - 6.281 Comentários

        Eu estaria usando uma versão ESR se houvesse alguma com o suporte aperfeiçoado a uma quantidade obscena de abas que saiu na versão 55.

        E segundo o calendário da Mozilla nunca vai existir uma que também suporte extensões XUL.

        • Luciano - 443 Comentários

          Ahm? Que nunca vai sair uma versão ESR que suporte essa desgraça do XUL?

          • Jefferson - 6.281 Comentários

            Eu li mais de cinco vezes e não entendi aonde você quer chegar.

            • Luciano - 443 Comentários

              Ahm? Quer dizer que nunca vai sair uma versão ESR que suporte essa desgraça do XUL?

              Ou seja a mozilla vai matar a versão ESR?

              • Jefferson - 6.281 Comentários

                Nunca vai sair outra versão do ESR que suporte XUL. A atual é a versão 52 e a próxima será a versão 59. Aliás, as duas versões, ESR e não-ESR serão lançadas ao mesmo tempo.

                Eu não entendi ainda por que você chama o XUL de “desgraça”.

              • Jefferson - 6.281 Comentários

                hummm… deve ser privação de sono. Afinal, você está comentando de dia. :-P

                • Luciano - 443 Comentários

                  Não é nada disso… :lol: É apenas confusão. A cabeça aqui tinha entendido que XUL era o novo formato para as extensões, enquanto que na verdade é o antigo. :S

                  Então reforme minha frase para: Quer dizer que a versão ESR também vai em breve parar o suporte as extensões de formato tradicional? A desgraça então é o novo formato.

                  Mas… vamos aguardar o desenrolar da coisa, pois das extensões que você citou no post anterior, a DownThenAll é uma que não abro mão.

                  Se os desenvolvedores chutarem o balde, ferrou. Eu só posso ter alguma esperança que alguém faça um fork ou consiga desenvolver um add-on do tipo “bridge” que consiga fazer as extensões antigas funcionar no navegador que use o novo formato.

                  E como eu disse inicialmente, eu sou contra essa sanha de atualização quase que semanal da Mozilla, antes de usar a versão ESR como disse, eu havia estacionado no Firefox 26. Só fui para a versão ESR quando ele já estava na 47 ou 48. Não será dificil eu segurar a bronca com a ESR 45 por muito tempo se necessário. Até que saia alguma soluçao, que seja qual for. Ou… que a maioria das paginas passe a funcionar erraticamente.

                  • Jefferson - 6.281 Comentários

                    ou consiga desenvolver um add-on do tipo “bridge” que consiga fazer as extensões antigas funcionar no navegador que use o novo formato.

                    Isso vai de inviável a impossível. Primeiro não poderia ser um add-on. Teria que ser um “hack” para expor as entranhas do Firefox. Segundo, teria que ser feito por alguém com profundo conhecimento dessas entranhas e com um tempo livre excepcional, para ficar adaptando o hack às constantes mudanças da Mozilla., problema exarcebado pela mentalidade da maioria , que vai ficar reclamando: “só tem suporte até a versão 1547 do Firefox? A versão 1548 já saiu faz três semanas!”. E um subconjunto desses vai acrescentar: “Se não pode atualizar essa m**da tira da internet!”

Deixe um comentário

Você pode usar estas tags HTML

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">

  

  

  

:) :( ;) O_o B) :lol: :huh: :S :D :-P 8-O :yahoo: :rtfm: :dashhead1: :clapping: more »